sv_port 0
.const std::vector<std::string> *aSortedNames
(std::string("embedded: ") + pName).c_str()
std::string
herestd::string
in this pr doesn't look very usefulstd::string
there has no advantagesstd::string
s need to be allocated (barring small string optimisation (which you can't rely on as it's not ensured by the standard))c++
NewWarning.m_WarningMsg = std::string("The width and height of texture");
if(pTexName && *pTexName)
{
NewWarning.m_WarningMsg.append(":\n\"");
NewWarning.m_WarningMsg.append(pTexName);
NewWarning.m_WarningMsg.append("\"\n");
}
NewWarning.m_WarningMsg.append("are not divisible by 16, which might cause visual bugs.");
str_format(aText, sizeof(aText), "%s%s%s", ":\n\"", pTexName, "\"\n");
@Deleted User why not add the \n in the format directly?extract_identifiers.py
to enforce identifier namingstd::vector<SGraphicsWarning> m_Warnings;
ok maybe this is a bit too much, but in sqlscore or similar, there is code using vector and naming it using a
prefix for arrays, idk if we should follow that (edited)m_v
m_l
before, it's all over the place for thosevoid PopupWarning(const char *pTopic, const char *pBody, const char *pButton, int64 Duration);
m_pMenus->PopupWarning("Warning!", pWarning->m_aWarningMsg, "Ok", 10000000);